Clear
Lead Graphic Papers

ข่าวสั้น

แจ้งเตือน OpenSSL ออกแพตช์แก้ไขช่องโหว่ระดับสูงจำนวน 2 จุด ผู้ใช้งานควรรีบอัปเดต

OpenSSL เป็นไลบรารี open source สำหรับใช้ในการเข้ารหัสลับข้อมูลผ่านโพรโทคอล SSL และ TLS ซึ่งมีซอฟต์แวร์หลายประเภทที่ใช้งาน OpenSSL เช่น ระบบปฏิบัติการ Linux, เว็บเซิร์ฟเวอร์, โปรแกรมแช็ท โปรแกรมสำหรับเชื่อมต่อ VPN เป็นต้น อย่างไรก็ตาม เมื่อวันที่ 25 มีนาคม 2564 OpenSSL ได้ออกแพตช์แก้ไขช่องโหว่ระดับสูง (High) จำนวน 2 จุด ส่งผลกระทบกับเวอร์ชัน 1.1.1 เป็นต้นไป ซึ่งผู้ใช้งานควรพิจารณาอัปเดตเพื่อปิดช่องโหว่

ช่องโหว่แรกมีรหัส CVE-2021-3449 เป็นช่องโหว่ประเภท Denial of Service (DoS) ส่งผลให้ผู้ไม่หวังดีสามารถส่งข้อความอันตรายเพื่อโจมตีเซิร์ฟเวอร์ OpenSSL จากเครื่อง client ส่งผลให้เครื่องเซิร์ฟเวอร์ไม่สามารถให้บริการได้ ช่องโหว่ที่สองมีรหัส CVE-2021-3450 เป็นเป็นช่องโหว่ประเภท Improper Certificate Authority ส่งผลให้เกิดความผิดพลาดในการตรวจสอบความถูกต้องของใบรับรอง

ทั้งนี้ เริ่มมีรายงานการเผยแพร่โค้ดสำหรับใช้โจมตีสำหรับช่องโหว่ CVE-2021-3449 แล้ว เพื่อหลีกเลี่ยงและป้องกันความเสี่ยงที่อาจเกิดขึ้น ผู้ใช้งาน OpenSSL เวอร์ชัน 1.1.1 เป็นต้นไปควรพิจารณาอัปเดตซอฟร์แวร์ให้เป็นเวอร์ชัน 1.1.1k โดยด่วน

วันที่: 2021-03-30 | ที่มา: OpenSSL | Share on Facebook Share on Twitter Share on Google+

Clear